Trunk between 3 switches

Image.png

Let say you have vlan10 in SW1 and SW3. Both switches have VTP in transparent mode.
Now between SW1 and SW3, we add SW2 with transparent vtp too.
We need to add all vlans that reside on SW1 and SW3 into SW2.
Even if those vlans not being used in any ports in SW2
NOTE:
-“vlan 10” in SW2 is important, without it I can’t ping PC2 from PC1

PC1
hostname PC1
interface Ethernet0/0
ip address 10.10.10.1 255.255.255.0

SW1
hostname SW1
vtp domain POC
vtp mode transparent
vlan 10
interface Ethernet0/0
switchport access vlan 10
switchport mode access
interface Ethernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk

SW2
hostname SW2
vtp domain POC
vtp mode transparent
vlan 10
interface Ethernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
interface Ethernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk

SW3
hostname SW3
vtp domain POC
vtp mode transparent
vlan 10
interface Ethernet0/0
switchport access vlan 10
switchport mode access
interface Ethernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk

PC2
hostname PC2
interface Ethernet0/0
ip address 10.10.10.2 255.255.255.0

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s