Named EIGRP

SOURCE:
Since IOS ver 15.2 Cisco support Named EIGRP.

Named EIGRP is Cisco’s attempt to improve the way you configure EIGRP. With Named EIGRP, all of the EIGRP routing process parameters reside in a single, hierarchical section of the running configuration. No longer are EIGRP commands scattered throughout the running configuration. Named EIGRP also provides consistency between the IPv4 and IPv6 EIGRP commands and their parameters.

With this Named mode, we can create a single Instance of EIGRP, which can be used for all address family type as shown above.

Another simplicity is if want to turn off the entire AS, you can use “shutdown” command under address-family to turn off the entire instance.
R1(config)#router eigrp HQ1
R1(config-router)#shutdown

Named EIGRP has 3 configuration modes. These are:
  1) address-family configuration mode – (config-router-af)#
  2) address-family interface configuration mode – (config-router-af-interface)#

  3) address-family topology configuration mode – (config-router-af-topology)#

A) Address-family configuration mode:
In this mode, you can configure networks, EIGRP neighbor, EIGRP Router-id, metric etc. From this mode you can access the other two configuration modes used in EIGRP named configuration.
R2(config-router)#address-family ipv4 unicast autonomous-system 1
R2(config-router-af)#?
Address Family configuration commands:
  af-interface            Enter Address Family interface configuration
  default                   Set a command to its defaults
  eigrp                     EIGRP Address Family specific commands
  exit-address-family Exit Address Family configuration mode
  help                      Description of the interactive help system
  maximum-prefix     Maximum number of prefixes acceptable in aggregate
  metric                   Modify metrics and parameters for address advertisement
  neighbor               Specify an IPv4 neighbor router
  network                Enable routing on an IP network
  no                        Negate a command or set its defaults
  shutdown              Shutdown address family
  timers                   Adjust peering based timers

  topology               Topology configuration mode

B) Address-family interface configuration mode:

This mode takes all the interface specific commands that were previously configured on an actual interface (logical or physical) and moves them into the EIGRP configuration. EIGRP authentication, Bandwidth-percentage, split-horizon, and summary-address configuration are some of the options that are now configured here instead of in interface configuration mode.

R2(config-router-af)#af-interface fa0/0
R2(config-router-af-interface)#?
Address Family Interfaces configuration commands:
authentication           authentication subcommands
bandwidth-percent    Set percentage of bandwidth percentage limit
bfd                          Enable Bidirectional Forwarding Detection
dampening-change   Percent interface metric must change to cause update
dampening-interval   Time in seconds to check interface metrics
default                    Set a command to its defaults
exit-af-interface       Exit from Address Family Interface configuration mode
hello-interval           Configures hello interval
hold-time                Configures hold time
next-hop-self           Configures EIGRP next-hop-self
no                          Negate a command or set its defaults
passive-interface     Suppress address updates on an interface
shutdown                Disable Address-Family on interface
split-horizon            Perform split horizon
summary-address    Perform address summarization

In traditional way if we want run EIGRP on all interface we use “network 0.0.0.0 0.0.0.0” command. Here you can use “af-interface default” to function same.
R2(config-router-af)#af-interface default

R2(config-router-af-interface)#

C) Address-family topology configuration mode:
This mode provide several options which operates on EIGRP topology table .here you can define content like redistribution, distance, offset list, variance etc. To enter this mode, we need to go back to address-family configuration mode:
R2(config-router-af-interface)#exit
R2(config-router-af)#topology base
R2(config-router-af-topology)#?
Address Family Topology configuration commands:
  auto-summary        Enable automatic network number summarization
  default                   Set a command to its defaults
  default-information  Control distribution of default information
  default-metric         Set metric of redistributed routes
  distance                 Define an administrative distance
  distribute-list          Filter entries in eigrp updates
  eigrp                     EIGRP specific commands
  exit-af-topology      Exit from Address Family Topology configuration mode
  fast-reroute           Configure Fast-Reroute
  maximum-paths     Forward packets over multiple paths
  metric                   Modify metrics and parameters for advertisement
  no                        Negate a command or set its defaults
  offset-list              Add or subtract offset from EIGRP metrics
  redistribute           Redistribute IPv4 routes from another routing protocol
  snmp                    Modify snmp parameters
  summary-metric    Specify summary to apply metric/filtering
  timers                   Adjust topology specific timers
  traffic-share          How to compute traffic share over alternate paths

  variance                Control load balancing variance

 Image.png
PC1:
hostname PC1
interface Ethernet0/0
 ip address 12.0.0.11 255.255.255.0

ip route 0.0.0.0 0.0.0.0 12.0.0.1

R1:
hostname R1
key chain MYCHAIN
 key 1
  key-string c1$c0
interface Loopback0
 ip address 1.0.0.1 255.255.255.255
interface Ethernet0/0
 ip address 23.0.0.1 255.255.255.0
interface Ethernet0/1
 ip address 12.0.0.1 255.255.255.0
router eigrp HQ1
 address-family ipv4 unicast autonomous-system 1
  af-interface Ethernet0/0
   authentication key-chain MYCHAIN
  exit-af-interface
  topology base
   redistribute static
  exit-af-topology
  network 1.0.0.0
  network 12.0.0.0
  network 23.0.0.0

 exit-address-family

R2:
hostname R2
key chain MYCHAIN
 key 1
  key-string c1$c0
interface Loopback0
 ip address 1.0.0.2 255.255.255.255
interface Ethernet0/0
 ip address 23.0.0.2 255.255.255.0
interface Ethernet0/1
 ip address 34.0.0.1 255.255.255.0
router eigrp HQ1
 address-family ipv4 unicast autonomous-system 1
  af-interface Ethernet0/0
   authentication key-chain MYCHAIN
  exit-af-interface
  topology base
   redistribute static
  exit-af-topology
  network 1.0.0.0
  network 23.0.0.0
  network 34.0.0.0

 exit-address-family

PC2:
hostname PC2
interface Ethernet0/0
 ip address 34.0.0.11 255.255.255.0
ip route 0.0.0.0 0.0.0.0 34.0.0.1
VERIFICATION
PC1#ping 34.0.0.11
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s