Trunk between two switches

Image.png

I want all PCs can ping each other even if 1 trunk link down.
I also want each vlan has vip as its gateway.
For that I will use GLBP
This lab scenario is using Unetlab L2 for the switches. Because of that, I need to disable “ip cef” on both switches.

SW1:
hostname SW1
vtp domain CISCO
vtp mode server
vtp version 3
vtp password c1$c0
vtp pruning
vtp mode server mst
vtp primary vlan
key chain MYCHAIN
key 1
key-string c1$c0
interface Loopback0
ip address 1.0.0.1 255.255.255.255
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 MYCHAIN
interface Port-channel1
switchport trunk allowed vlan 1,10,20
switchport trunk encapsulation dot1q
switchport mode trunk
interface Ethernet0/0
switchport trunk allowed vlan 1,10,20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
interface Ethernet0/1
switchport trunk allowed vlan 1,10,20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
interface Ethernet0/2
switchport access vlan 10
switchport mode access
interface Ethernet0/3
switchport access vlan 20
switchport mode access
interface Vlan10
ip address 10.0.0.2 255.255.255.0
glbp 1 ip 10.0.0.1
glbp 1 authentication md5 key-chain MYCHAIN
interface Vlan20
ip address 20.0.0.2 255.255.255.0
glbp 1 ip 20.0.0.1
glbp 1 authentication md5 key-chain MYCHAIN
router eigrp 1
network 1.0.0.0 0.0.0.255
network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
redistribute static

SW2:
hostname SW2
vtp domain CISCO
vtp mode client
vtp version 3
vtp password c1$c0
vtp pruning
key chain MYCHAIN
key 1
key-string c1$c0
interface Loopback0
ip address 1.0.0.2 255.255.255.255
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 MYCHAIN
interface Port-channel1
switchport trunk allowed vlan 1,10,20
switchport trunk encapsulation dot1q
switchport mode trunk
interface Ethernet0/0
switchport trunk allowed vlan 1,10,20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
interface Ethernet0/1
switchport trunk allowed vlan 1,10,20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
interface Ethernet0/2
switchport access vlan 10
switchport mode access
interface Ethernet0/3
switchport access vlan 20
switchport mode access
interface Vlan10
ip address 10.0.0.3 255.255.255.0
glbp 1 ip 10.0.0.1
glbp 1 authentication md5 key-chain MYCHAIN
interface Vlan20
ip address 20.0.0.3 255.255.255.0
glbp 1 ip 20.0.0.1
glbp 1 authentication md5 key-chain MYCHAIN
router eigrp 1
network 1.0.0.0 0.0.0.255
network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
redistribute static

PC1:
hostname PC1
interface Ethernet0/0
ip address 10.0.0.11 255.255.255.0
ip route 0.0.0.0 0.0.0.0 10.0.0.1

PC2:
hostname PC2
interface Ethernet0/0
ip address 20.0.0.11 255.255.255.0
ip route 0.0.0.0 0.0.0.0 20.0.0.1

PC3:
hostname PC3
interface Ethernet0/0
ip address 10.0.0.12 255.255.255.0
ip route 0.0.0.0 0.0.0.0 10.0.0.1

PC4:
hostname PC4
interface Ethernet0/0
ip address 20.0.0.12 255.255.255.0
ip route 0.0.0.0 0.0.0.0 20.0.0.1

-verify etherchannel link
SW1#sh etherchannel sum
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use N – not in use, no aggregation
f – failed to allocate aggregator
M – not in use, minimum links not met
m – not in use, port not aggregated due to minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port
A – formed by Auto LAG
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) LACP Et0/0(P) Et0/1(P)

SW1#sh etherchannel detail
Channel-group listing:
———————-
Group: 1
———-
Group state = L2
Ports: 2 Maxports = 4
Port-channels: 1 Max Port-channels = 4
Protocol: LACP
Minimum Links: 0
Ports in the group:
——————-
Port: Et0/0
————
Port state = Up Mstr Assoc In-Bndl
Channel group = 1 Mode = Active Gcchange = –
Port-channel = Po1 GC = – Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S – Device is sending Slow LACPDUs F – Device is sending fast LACPDUs.
A – Device is in active mode. P – Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Et0/0 SA bndl 32768 0x1 0x1 0x1 0x3D
Partner’s information:
LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Et0/0 SA 32768 aabb.cc80.0200 14s 0x0 0x1 0x1 0x3D
Age of the port in the current state: 0d:00h:11m:23s
Port: Et0/1
————
Port state = Up Mstr Assoc In-Bndl
Channel group = 1 Mode = Active Gcchange = –
Port-channel = Po1 GC = – Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S – Device is sending Slow LACPDUs F – Device is sending fast LACPDUs.
A – Device is in active mode. P – Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Et0/1 SA bndl 32768 0x1 0x1 0x2 0x3D
Partner’s information:
LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Et0/1 SA 32768 aabb.cc80.0200 13s 0x0 0x1 0x2 0x3D
Age of the port in the current state: 0d:00h:41m:48s
Port-channels in the group:
—————————
Port-channel: Po1 (Primary Aggregator)
————
Age of the Port-channel = 0d:02h:07m:32s
Logical slot/port = 16/0 Number of ports = 2
HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = LACP
Port security = Disabled
Ports in the Port-channel:
Index Load Port EC state No of bits
——+——+——+——————+———–
0 00 Et0/0 Active 0
0 00 Et0/1 Active 0
Time since last port bundled: 0d:00h:11m:23s Et0/0
Time since last port Un-bundled: 0d:00h:41m:56s Et0/1

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s