Cisco CUCM Tips

  1. Basic Server Configuration
    go to Navigation/Cisco Unified CM Administration
    click System/Server
    click Find
    click server name and replace hostname with its ip address “Host Name/IP Address”
    click Save
  2. Basic Network Configuration
    Configure 3750 DHCP and QOS
    vtp domain poc
    vtp mode transparent
    ip routing
    no ip domain-lookup
    ip domain-name poc.com
    ip name-server 10.0.20.2
    ip dhcp excluded-address 10.0.40.1 10.0.40.100
    ip dhcp excluded-address 10.0.40.200 10.0.40.254
    !
    ip dhcp pool PocDhcpVoicePool
    network 10.0.40.0 255.255.255.0
    dns-server 10.0.20.2
    default-router 10.0.40.1
    option 150 ip 10.0.10.77
    lease 5
    !
    vlan 30
    name USR
    !
    vlan 40
    name VOICE
    !
    class-map match-all AUTOQOS_VOIP_DATA_CLASS
    match ip dscp ef
    class-map match-all AUTOQOS_DEFAULT_CLASS
    match access-group name AUTOQOS-ACL-DEFAULT
    class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
    match ip dscp cs3
    !
    policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY
    class AUTOQOS_VOIP_DATA_CLASS
    set dscp ef
    police 128000 8000 exceed-action policed-dscp-transmit
    class AUTOQOS_VOIP_SIGNAL_CLASS
    set dscp cs3
    police 32000 8000 exceed-action policed-dscp-transmit
    class AUTOQOS_DEFAULT_CLASS
    set dscp default
    police 10000000 8000 exceed-action policed-dscp-transmit
    !
    interface FastEthernet2/0/21
    switchport access vlan 30
    switchport mode access
    switchport voice vlan 40
    speed 100
    duplex full
    srr-queue bandwidth share 1 30 35 5
    priority-queue out
    mls qos trust device cisco-phone
    mls qos trust cos
    auto qos voip cisco-phone
    spanning-tree portfast
    service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
    !
    interface FastEthernet2/0/22
    switchport access vlan 30
    switchport mode access
    switchport voice vlan 40
    speed 100
    duplex full
    srr-queue bandwidth share 1 30 35 5
    priority-queue out
    mls qos trust device cisco-phone
    mls qos trust cos
    auto qos voip cisco-phone
    spanning-tree portfast
    service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
    !
    interface Vlan30
    ip address 10.0.30.1 255.255.255.0
    ip helper-address 10.0.20.2
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip pim sparse-mode
    !
    interface Vlan40
    ip address 10.0.40.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip pim sparse-mode
    !
    ip access-list extended AUTOQOS-ACL-DEFAULT
    permit ip any any
  3. To add Universal Line Template
    go to User Management/User Phone Add/Universal Line Template
    click Add New
    Name: AutoReg Universal Line Template
    Line Description: #FirstName# #LastName# (#UserID#)
    Route Partition: POC-HQ-P-LOCAL
    Voice Mail Profile: Default
    Alerting Name: #FirstName# #LastName#
  4. To add Universal Device Template
    go to User Management/User Phone Add/Universal Device Template
    click Add New
    Name: AutoReg Universal Device Template
    Device Description: #FirstName# #LastName# (#Product# #Protocol#)
    Device Pool: Default
    Device Security Profile: Universal Device Template – Model-independent Security Profile
    SIP Profile: Standard SIP Profile
    Phone Button Template: Universal Device Template Button Layout
  5. To add User Profile
    go to User Management/User Settings/Service Profile
    click Find
    click Standard (Factory Default) User Profile
    Name: Standard (Factory Default) User Profile
    tick Make this the default User Profile for the system
    Desk Phones: AutoReg Universal Device Template
    Mobile and Desktop Devices: AutoReg Universal Device Template
    Remote Destination/Device Profiles: AutoReg Universal Device Template
    Universal Line Template: AutoReg Universal Line Template
    tick Allow End User to Provision their own phones
    Limit Provisioning once End User has this many phones: 10
  6. Modify CM Group
    go to System/Cisco Unified CM Group
    click Find
    click Default
    Name: POC-SYS-CUCMG
    tick Auto-registration Cisco Unified Communication Manager Group
    Selected Cisco Unified Communications Managers:
    click Save
  7. To activate Services
    go to CUCM Navigation/Cisco Unified Serviceability
    click Tools/Service Activation
    tick Cisco CllManager, Cisco IP Voice Media Streaming App, Cisco CTIManager, Cisco Extension Mobility, Cisco Extended Functions, Cisco TFTP, Cisco IP Manager Assistant, Cisco WebDIaler Web Service, Self Provisioning IVR, Cisco CAR Web Service, Cisco Bulk Provisioning Service, Cisco AXL Web Service, Cisco Serviceability Reporter, Cisco DIRSync
    click Save
  8. To set System Date/Time
    go to System/Date Time Group
    Time Zone: POC-SYS-GMT7
    Date Format: D-M-Y
    click Save
  9. To set System Region
    go to System/Region Information/Region
    Name: POC-HQ-REG
    click Save
    click Regions/Default Maximum Audio Bit Rate: 8 kbps (G.729)
    click Save
    click Regions/POC-HQ-REG Maximum Audio Bit Rate: 64 kbps (G.722, G.711)
    click Save
  10. To set Device Pool
    go to Navigation/Cisco Unified CM Administration
    click System/Device Pool/Default
    Device Pool Name: POC-HQ-DP
    Cisco Unified Communications Manager Group: POC-SYS-CUCMG
    Calling Search Space for Auto-registration: POC-SYS-AUTOREG
    Date/Time Group: POC-SYS-GMT7
    Region: POC-SYS-GMT7
    cick Save
  11. To add LDAP
    http://www.markholloway.com/blog/?p=1189
    go to Windows 2012R2 ADUC
    in each user, add
    First name, Last name, Telephone number (extension number)
    Last name is important, without it, user can’t be synced to CUCM
    go to CUCM Navigation/Cisco Unified CM Administration
    click System/LDAP/LDAP System
    tick Enable Synchronizing from LDAP Server
    LDAP Server Type: Microsoft Active Directory
    LDAP Attribute for User ID: sAMAccountName
    click Save
    click System/LDAP/LDAP Authentication
    tick Use LDAP Authentication for End Users
    LDAP Manager Distinguished Name: Administrator@poc.com
    LDAP Password:
    Confirm Password:
    LDAP User Search Base: ou=HQUSR,ou=HQ,dc=poc,dc=com
    Host Name or IP Address for Server: 10.0.20.2
    click Save
    click System/LDAP/LDAP Directory
    LDAP Configuration Name: POC-HQ-LDAP
    LDAP Manager Distinguished Name: Administrator@poc.com
    LDAP Password:
    Confirm Password:
    LDAP User Search Base: ou=HQUSR,ou=HQ,dc=poc,dc=com
    Perform Re-sync Every: 1 DAY
    Host Name or IP Address for Server: 10.0.20.2
    click Save
    Verify user AD users added into CUCM
    click User Management/End Users
    click Find
  12. To add Media Resources
    go to Navigation/Cisco Unified CM Administration
    click Media Resources/Media Termination Point
    click Find
    change “Media Termination Point Name” to the same as Description
    Device Pool: POC-HQ-DP
    click Save
    click Reset
    click Media Resources/Media Resource Group
    click Add New
    Name: POC-HQ-MRG
    Selected Media Resources: MTP_cucm (MTP)
    click Save
    click Media Resources/Media Resource Group List
    click Add New
    Name: POC-HQ-MRGL
    Selected Media Resource Group: POC-HQ-MRG
    click Save
    click System/Device Pool
    click Find
    click POC-HQ-DP
    Media Resource Group List: POC-HQ-MRGL
  13. To add SCCP Phone
    plug the phone into port 21 or 22 in 3750
    check the phone registered in CM Administration
    go to Navigation/Cisco Unified CM Administration
    click Device/Phone
  14. To add SIP Phone
    go to Navigation/Cisco Unified CM Administration
    click System/Security/Phone Security Profile
    click Find
    go to last page
    click Third-party SIP Device Basic – Standard SIP Non-Secure Profile
    click Copy
    Name: POC-SYS-PSP
    tick Enable Digest Authentication
    click Save
    click User Management/End User
    click target user
    PIN:
    Confirm PIN:
    Digest Credentials:
    Confirm Digest Credentials:
    click Save
    click Device/Phone
    click Add New
    Phone Type: Third-party SIP Device (Basic)
    click Next
    MAC Address: 000000001011
    Device Pool: POC-HQ-DP
    Phone Button Template: Third-party SIP Device (Basic)
    Common Phone Profile: Standard Common Phone Profile
    Calling Search Space: POC-HQ-CSS-EMPLOYEES
    Media Resource Group List: POC-HQ-MRGL
    Owner User ID: user3
    Device Security Profile: POC-HQ-PSP
    Security Profile: Standard SIP Profile
    tick Media Termination Point Required
    click Save
    click Line [1] – Add a new DN
    Directory Number: 1011
    Route Partition: POC-HQ-P-PHONES
    Description: Adam (x1011)
    Alerting Name: Adam (x1011)
    ASCII Alerting Name: Adam (x1011)
    Calling Search Space: POC-HQ-CSS-EMPLOYEES
    Forward All: POC-HQ-CSS-EMPLOYEES
    Secondary Calling Search Space for Forward All: POC-HQ-CSS-EMPLOYEES
    Forward Busy Internal: POC-HQ-CSS-EMPLOYEES
    Forward Busy External: POC-HQ-CSS-EMPLOYEES
    Forward No Answer Internal: POC-HQ-CSS-EMPLOYEES
    Forward No Answer External: POC-HQ-CSS-EMPLOYEES
    Forward No Coverage Internal: POC-HQ-CSS-EMPLOYEES
    Forward No Coverage External: POC-HQ-CSS-EMPLOYEES
    Forward on CTI Failure: POC-HQ-CSS-EMPLOYEES
    Forward Unregistered Internal: POC-HQ-CSS-EMPLOYEES
    Forward Unregistered External: POC-HQ-CSS-EMPLOYEES
    No Answer Ring Duration (seconds): 10
    Display (Caller ID): Adam (x1011)
    ASCII Display (Caller ID): Adam (x1011)
    External Phone Number Mask: +6221522XXXX
    click Device/Phone
    click the SIP Phone we created earlier
    Description: Adam (x1011)Click Call Routing/Directory Number
    make sure all extension Route Partition: None (empty)
  15. SIP Client Settings
    Download ippi Messenger from http://www.ippi.com.
    Ippi beside SIP2SIP, it can do Skype2SIP or SIP2Skype.
    Compare to Zoiper, Zoiper can’t do Authorization. Authorization is important when you want to connect to CUCM if you implement SIP Security Profile.
    You don’t want unauthorized user to join your SIP network right
    Here ippi Messenger settings
    click Tools/Options
    click Accounts
    click Add
    SIP id: 1011@10.0.10.77
    Password: 1234 (the password in User Management/End User/user/Digest Credentials)
    Display name: 1011
    click Connection
    Authorization name: adam (ADUC/Account/User logon name)Another alternative is X-Lite, but I still prefer IPPI Messenger because can receive and call from Skype or GTalk
    Download X-Lite from http://www.counterpath.com/x-lite-download/
    click Softphone/Account Settings
    Account Name: Cisco
    User ID: 1012
    Domain: 10.0.10.77
    Password: 1234 (the password in User Management/End User/user/Digest Credentials)
    Display name: 1012
    Authorization name: brian (ADUC/Account/User logon name)
    tick Register with domain and receive calls
    Send outbound via: Domain
  16. To upgrade phone firmware
    Download phone firmware from http://www.cisco.com/c/en/us/support/index.html
    click Downloads and type your phone model for example 7912G
    click Skinny Client Control Protocol (SCCP)/Software-8.0(4)
    click Download on cmterm-7912-8.0.4-sccp.cop.sgn
    check its md5
    move it into c:\SFTP
    Download and run http://www.coreftp.com/server/download/msftpsrvr.exe
    Allow port 22 Inbound Firewall rule in your windows
    Set c:\SFTP as root folder of msftpsrvr.exe
    go to Navigation/Cisco Unified OS Administration
    click Software Upgrades/Install Upgrade
    Source: Remote Filesystem
    Directory: /
    Server: 10.0.10.111
    User Name: cisco
    User Password: password
    Transfer Protocol: SFTP
    click Next
    Make sure Options/Upgrades shown correct firmware
    click Next
    click Next
    go to Navigation/Cisco Unified Serviceability
    click Tools/Control Center Feature Services
    click Cisco TFTP
    click Restart
    Verify firmware has beem successfully installed in server
    go to Navigation/Cisco Unified CM Administration
    click Device/Device Settings/Device Defaults
    reboot the phone
    click Device/Phone
    type user and click Find
    click IP Address to find current firmware of the phone
    tick the phone and click Reset Selected
  17. To change ip address only
    admin:set network ip eth0 10.0.10.77 255.255.255.0 10.0.10.1
    WARNING: Changing this setting will invalidate software license on this server.
    The license will have to be re-hosted.
    Continue (y/n)?
  18. To change ip address and hostname
    change cucm ip address and hostname in dns first
    admin:set network hostname
    WARNING: To avoid license synchronization failures, delete the product instance from the Cisco Prime License Manager managing this server’s licenses before changing network settings.You will have to re-add the product instance after the network settings have been changed.
    This Operation would take time as Certificates need to be regenerated.
    Continue (y/n)?y
    ctrl-c: To quit the input.
    *** W A R N I N G ***
    Do not close this window without first canceling the command.
    This command will automatically restart system services.
    The command should not be issued during normal operating hours.
    =======================================================
    Note: Please verify that the new hostname is a unique name across the cluster and, if DNS services are utilized, any DNS configuration is completed before proceeding.
    =======================================================
    Security Warning : This operation will regenerate all CUCM Certificates including any third party signed Certificates that have been uploaded.
    Enter the hostname:: cucm
    Would you like to change the network ip address at this time [yes]::
    Warning: Do not close this window until command finishes.
    ctrl-c: To quit the input.
    *** W A R N I N G ***
    =======================================================
    Note: Please verify that the new ip address is unique across the cluster.
    =======================================================
    Enter the ip address:: 10.0.10.77
    Enter the ip subnet mask:: 255.255.255.0
    Enter the ip address of the gateway:: 10.0.10.1
    Hostname: cucm
    IP Address: 10.0.10.77
    IP Subnet Mask: 255.255.255.0
    Gateway: 10.0.10.1
    Do you want to continue [yes/no]? yes
  19. To ping from cucm
    admin:utils network ping 10.0.10.1
    To change security password
    admin:set password user security
    Please enter the old password: **********
    Please enter the new password: *********
    Reenter new password to confirm: *********
    WARNING:
    The Disaster Recovery System is dependent on this security password you are attempting to change.If you need to use any of the older backup archive to restore this system, you need to remember theolder security password. To avoid this scenario, we recommend you to conduct a DRS Backup of yoursystem/cluster immediately after this password change.Please make sure that the security password on the publisher is changed first.The security password needs to be the same on all cluster nodes,or the publisher and subscriber(s) will not communicate.After changing the security password on a cluster node, please restart that node.
    Continue (y/n)?y
  20. To restart
    GUI
    click Navigation/Cisco Unified OS Administration
    click Go
    click Settings/Version
    CLI
    admin:utils system restart
    Do you really want to restart?
    Enter (yes/no)? yes
  21. To shutdown
    GUI
    click Navigation/Cisco Unified OS Administration
    click Go
    click Settings/Version
    CLI
    admin:utils system shutdown
    Do you really want to shutdown ?
    Enter (yes/no)? yes
  22. To trace CUCM SIP Trunk to PSTN Troubleshooting
    go to Navigation/Cisco Unified Serviceability
    click Trace/Configuration
    Image
    click Save
    Related Links: SDI Configuration
    click Go
    Image
    click SaveInstall RTMT
    go to Navigation/Cisco Unified CM Administration
    click Application/Plugins
    click Download/Cisco Unified Real-Time Monitoring Tool Windows
    install and run
    open Cisco Real Time Monitoring Tool
    click 2x Tools/Trace & Log Central/Real Time Trace/View Real Time
    Nodes: cucm.poc.com
    Category: UCM
    Services: Cisco Call Manager
    Trace File Type: sdl
    After finish using Trace, please disable Trace On in
    click Trace/Configuration
    Server: CUCM server ip
    Service Group: CM Services
    Service: Cisco Call Manager (Active)
  23. To gather trace file
    open RTMT
    click AnalysisManager/Preferences/Trace Collection
    set Download Directory
    click Save
    click AnalysisManager/Inventory/Trace templates
    click Add
    Name: CallManager
    tick Cisco CallManager
    click Save
    click AnalysisManager/Tools/Collect Traces Now
    Use Template: CallManager
  24. To read trace file
    open RTMT
    click System/Tools/Trace & Log Central menu
    click 2x Local Browse
    open trace file as you set in AnalysisManager/Preferences/Trace Collection/Download Directory
  25. To delete trace file
    login as admin in cucm
    to see all of the trace folders type in the following
    # file list activelog /cm/trace/*
    to see all of the CUCM SDI traces type in the following
    # file list activelog /cm/trace/ccm/sdi/*
    now to delete them, type the following
    # file delete activelog /cm/trace/ccm/sdi/* noconfirm
  26. To set Alert email server in RTMT
    click System/Tools/Alert/Config Email Server
  27. To fix “HTTP Status 404 – /ccmadmin/showHome.do”
    admin:utils service list page
    System SSH [STARTED]
    Cluster Manager [STARTED]
    Cisco SCSI Watchdog [STARTED]
    Service Manager [STARTED]
    Service Manager is running
    Getting list of all services
    A Cisco DB[STARTED]
    A Cisco DB Replicator[STARTED]
    Cisco AMC Service[STARTED]
    Cisco AXL Web Service[STOPPED] Component is not running
    Cisco Audit Event Service[STARTED]
    Cisco Bulk Provisioning Service[STARTED]
    Cisco CAR DB[STARTED]
    Cisco CAR Scheduler[STARTED]
    Cisco CAR Web Service[STOPPED] Component is not running
    Cisco CDP[STARTED]
    Cisco CDP Agent[STARTED]
    Cisco CDR Agent[STARTED]
    Cisco CDR Repository Manager[STARTED]
    Cisco CTIManager[STARTED]
    Cisco CallManager[STARTED]
    Cisco CallManager Admin[STOPPED] Component is not running
    Cisco CallManager Cisco IP Phone Services[STOPPED] Component is not running
    Cisco CallManager Personal Directory[STOPPED] Component is not running
    Cisco CallManager Serviceability[STOPPED] Component is not running
    Cisco CallManager Serviceability RTMT[STOPPED] Component is not running
    Cisco Certificate Change Notification[STARTED]
    Cisco Certificate Expiry Monitor[STARTED]
    Cisco Change Credential Application[STOPPED] Component is not running
    Cisco DRF Local[STARTED]
    Cisco DRF Master[STARTED]
    Cisco Database Layer Monitor[STARTED]
    Cisco DirSync[STARTED]
    Cisco E911[STOPPED] Component is not running
    Cisco ELM Client Service[STOPPED] Component is not running
    Cisco Extended Functions[STARTED]
    Cisco Extension Mobility[STOPPED] Component is not running
    Cisco Extension Mobility Application[STOPPED] Component is not running
    Cisco IP Manager Assistant[STOPPED] Component is not running
    Cisco IP Voice Media Streaming App[STARTED]
    Cisco License Manager[STARTED]
    Cisco Log Partition Monitoring Tool[STARTED]
    Cisco Prime LM Admin[STOPPED] Component is not running
    Cisco Prime LM DB[STARTED]
    Cisco Prime LM Server[STARTED]
    Cisco RIS Data Collector[STARTED]
    Cisco RTMT Reporter Servlet[STOPPED] Component is not running
    Cisco SOAP – CallRecord Service[STARTED]
    Cisco Serviceability Reporter[STARTED]
    Cisco Syslog Agent[STARTED]
    Cisco Tftp[STARTED]
    Cisco Tomcat[STARTED]
    Cisco Tomcat Stats Servlet[STOPPED] Component is not running
    Cisco Trace Collection Service[STARTED]
    Cisco Trace Collection Servlet[STOPPED] Component is not running
    Cisco Trust Verification Service[STARTED]
    Cisco User Data Services[STOPPED] Component is not running
    Cisco WebDialer Web Service[STOPPED] Component is not running
    Host Resources Agent[STARTED]
    MIB2 Agent[STARTED]
    Platform Administrative Web Service[STOPPED] Component is not running
    SNMP Master Agent[STARTED]
    SOAP – Diagnostic Portal Database Service[STARTED]
    SOAP -Log Collection APIs[STARTED]
    SOAP -Performance Monitoring APIs[STARTED]
    SOAP -Real-Time Service APIs[STARTED]
    Self Provisioning IVR[STARTED]
    System Application Agent[STARTED]
    Cisco CTL Provider[STOPPED] Service Not Activated
    Cisco CallManager SNMP Service[STOPPED] Service Not Activated
    Cisco Certificate Authority Proxy Function[STOPPED] Service Not Activated
    Cisco DHCP Monitor Service[STOPPED] Service Not Activated
    Cisco Dialed Number Analyzer[STOPPED] Service Not Activated
    Cisco Dialed Number Analyzer Server[STOPPED] Service Not Activated
    Cisco Directory Number Alias Lookup[STOPPED] Service Not Activated
    Cisco Directory Number Alias Sync[STOPPED] Service Not Activated
    Cisco Intercluster Lookup Service[STOPPED] Service Not Activated
    Cisco Location Bandwidth Manager[STOPPED] Service Not Activated
    Cisco Prime LM Resource API[STOPPED] Service Not Activated
    Cisco Prime LM Resource Legacy API[STOPPED] Service Not Activated
    Cisco SOAP – CDRonDemand Service[STOPPED] Service Not Activated
    Cisco TAPS Service[STOPPED] Service Not Activated
    Cisco UXL Web Service[STOPPED] Service Not Activated
    Cisco Unified Mobile Voice Access Service[STOPPED] Service Not Activated
    Primary Node =true
    Admin: utils service start Cisco Tomcat
  28. To backup and restore
    Download and run http://www.coreftp.com/server/download/msftpsrvr.exe
    Allow port 22 Inbound Firewall rule in your windows
    Make sure “Backup and Restore Services” are running
    go to Navigation/Cisco Unified Serviceability
    click Go
    click Tools/Control Center – Network Services
    check both services in “Backup and Restore Services” are running
    Backup
    go to Navigation/Disaster Recovery System
    click Go
    click Backup/Backup Device
    click Add New
    Backup device name: POC-SFTP
    Host name/IP address: 10.0.10.112
    Path name: /
    User name: cisco
    Password: password
    click Save
    go to Backup/Manual Backup menu
    select Device Name: POC-SFTP
    select what you want to backup in Select Feature
    click Start Backup
    check backup status SUCCESS in Backup/Current Status menu
    we can check when backup happen in Backup/Backup History menu
    we can set backup schedule in Backup/Scheduler menu
    Restore
    click Restore/Restore Wizard menu
    click Device/Phone to check if phone restored
    click Call Routing/Class of Control/Partition to check all partition exist
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s