Cisco CME + Ext FXO FXS + Ext FWT Configuration

Image

For CME, I am using 2811 with FXS and FXO card. PVDM card is not coming yet.
Outgoing call, so far ok. Incoming call from DID SIP Trunk ok.
Incoming call from FWT need to be fixed.
So far the best SIP Trunk I ever test is DIDLogic.
It has no problem with NAT and DID Incoming Call
Let’s start with the configuration
Cisco CME:
#sh run
version 15.1
hostname RTR2811a
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.151-4.M10.bin
warm-reboot count 10 uptime 7
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/1
no logging buffered
aaa new-model
aaa session-id common
clock timezone Bangkok 7 0
!
dot11 syslog
ip source-route
ip cef
!
no ip domain lookup
ip domain name poc.com
ip name-server 8.8.8.8
ip name-server 8.8.4.4
no ipv6 cef
multilink bundle-name authenticated
!
voice service voip
ip address trusted list
ipv4 192.170.159.194 255.255.255.255
ipv4 54.251.255.196 255.255.255.255
ipv4 10.0.10.0 255.255.255.0
ipv4 10.0.20.0 255.255.255.0
ipv4 10.0.30.0 255.255.255.0
ipv4 10.0.40.0 255.255.255.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
bind control source-interface FastEthernet0/0
bind media source-interface FastEthernet0/0
registrar server expires max 600 min 60
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice register global
mode cme
source-address 10.0.10.206 port 5060
max-dn 144
max-pool 35
authenticate realm poc.com
tftp-path flash:
file text
create profile sync 0004537381553206
!
voice register dn 1
number 812
name user delapansatudua
shared-line
label 812
!
voice register pool 1
id mac 0000.0000.0812
number 1 dn 1
username 812 password 123
codec g711ulaw
!
voice translation-rule 9
rule 1 /\(^9\)/ //
!
voice translation-rule 628
rule 1 /^628/ /08/
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.10.206 255.255.255.0
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.31.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
!
router eigrp 1
network 1.1.1.1 0.0.0.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http secure-port 8443
ip http timeout-policy idle 60 life 86400 requests 10000
ip pim rp-address 1.1.1.1
ip nat inside source list 101 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 10.0.10.1
!
ip access-list standard blockedhost
deny 46.165.249.4
deny 118.136.227.177
permit any
tftp-server flash:CP7912080004SCCP080108A.sbin alias CP7912080004SCCP080108A.sbin
control-plane
call threshold global cpu-avg low 68 high 75
call threshold global total-mem low 75 high 85
ccm-manager music-on-hold
mgcp fax t38 ecm
mgcp profile default
!
dial-peer voice 1 voip
description Outgoing SIP DIDLogic
translation-profile outgoing 9
destination-pattern [+,9]1[2-9]..[2-9]……
session protocol sipv2
session target dns:sip.sg.didlogic.net
voice-class codec 1
dtmf-relay sip-notify
!
dial-peer voice 10 voip
answer-address 801
destination-pattern 14159172008
session target dns:sip.sg.didlogic.net
voice-class codec 1
!
dial-peer voice 20 voip
answer-address 801
destination-pattern 85258010007
session protocol sipv2
session target dns:sip1.hoiio.com
voice-class codec 1
!
dial-peer voice 6 voip
description Outgoing SIP Hoiio
translation-profile outgoing 9
destination-pattern [+,9]852……..
session protocol sipv2
session target dns:sip1.hoiio.com
voice-class codec 1
dtmf-relay sip-notify
!
dial-peer voice 11 voip
description Outgoing SIP Planet
translation-profile outgoing 9628
destination-pattern [+628,908]……..T
session protocol sipv2
session target ipv4:10.0.10.87
codec g711ulaw
dial-peer voice 2 voip
!
num-exp 85258010007 801
num-exp 14159172008 801
num-exp 081298998288 801
sip-ua
credentials username 1001 password 7 025756085F5123 realm 10.0.10.87
credentials username 08843 password 7 01232617481C561123 realm sip.sg.didlogic.net
credentials username sip7228254 password 7 044A04030475786A254809033B2123 realm sip1.hoiio.com
authentication username 08843 password 7 15222B1F173D7B36123 realm sip.sg.didlogic.net
authentication username sip7228254 password 7 06170024471A3D3D29461E1F252123 realm sip1.hoiio.com
authentication username 1001 password 7 00554155500123 realm 10.0.10.87
registrar 1 dns:sip.sg.didlogic.net expires 3600
registrar 2 dns:sip1.hoiio.com expires 3600
registrar 3 ipv4:10.0.10.87 expires 3600
sip-server dns:sip.didlogic.net
!
telephony-service
no auto-reg-ephone
max-ephones 35
max-dn 144
ip source-address 10.0.10.206 port 2000
max-redirect 5
cnf-file location flash:
date-format dd-mm-yy
max-conferences 8 gain -6
moh flash:/Wave.au
multicast moh 239.1.1.1 port 2000 route 10.0.10.1
web admin system name admin secret 5 $1$JGDo$afA54af/90u3S4gnt0s123
transfer-system full-consult
create cnf-files version-stamp 7960 Sep 05 2015 12:47:31
!
ephone-dn 1 dual-line
number 801 no-reg both
label Operator (x801)
name user delapannolsatu
!
ephone-dn 2 dual-line
number 802 no-reg both
label Sales (x802)
!
ephone-dn 3 dual-line
number 803 no-reg both
label CS (x803)
mobility
snr +6287809777123 delay 10 timeout 30
!
ephone-dn 4
number 888 no-reg both
name POC-Paging
paging ip 239.1.1.2 port 2000
!
ephone 1
device-security-mode none
mac-address 000B.BE3B.9E9C
username “u801” password 123
paging-dn 4
type 7912
button 1:1
!
ephone 2
device-security-mode none
mac-address 0012.0127.A14A
paging-dn 4
type 7912
button 1:2
!
ephone 3
device-security-mode none
mac-address E0DB.55A9.B3D5
paging-dn 4
type CIPC
button 1:3
!
line con 0
line aux 0
line vty 0 4
privilege level 15
transport input telnet
transport output telnet
line vty 5 15
privilege level 15
transport input ssh
transport output ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 202.162.32.12
end

Planet VIP-480:
01-Sep 21.07.52

01-Sep 21.06.30

01-Sep 21.06.02

01-Sep 21.05.18

SIP CLIENT SETTINGS:
Zoiper
Settings/Preferences/Accounts/General
Domain: 10.0.10.206
Username: 812
Password:
Caller ID Name: 812
Auth. username: 812
tick Use outbound proxy
Outbound proxy: 10.0.10.206
Settings/Preferences/Accounts/Extra
tick Register on startup
Settings/Preferences/Accounts/Codec
Selected codecs: u-law first
Settings/Preferences/Accounts/Advanced
Use DTMF RFC-2833
Use UDP transport
TLS with no SRTP
Don’t use STUN

CSipSimple
Account name: Cisco
User: 812
Server: 10.0.10.206
Password:

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s