IP NAT

I want to share my internet access to my user pcs
Here the diagram
PC—fa0/1(192.168.88.1)-ROUTER-fa0/0—INTERNET(10.0.0.1)

In global config, I just show common config
#sh run
ip dhcp excluded-address 192.168.88.1 192.168.88.100
ip dhcp excluded-address 192.168.88.201 192.168.88.254
ip dhcp pool LANpool
network 192.168.88.0 255.255.255.0
domain-name poc.local
default-router 192.168.88.1
dns-server 8.8.8.8 8.8.4.4
lease 7
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.88.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
access-list 1 permit 192.168.88.0 0.0.0.255

PAT:
1 external ip shared with many internal ip
(config)#ip nat inside source list 1 interface FastEthernet0/0 overload
#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 10.0.0.102:59771 192.168.88.101:59771 173.194.117.94:443 173.194.117.94:443
tcp 10.0.0.102:59727 192.168.88.101:59727 198.252.206.25:80 198.252.206.25:80

Dynamic NAT
1 dynamic external ip shared with 1 internal ip
(config)#ip nat pool DNATpool 10.0.0.101 10.0.0.110 netmask 255.255.255.0
(config)#ip nat inside source list 1 pool DNATpool
#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
— 10.0.0.101 192.168.88.101 — —

Static NAT
1 static external ip shared with 1 internal ip
#sh run
ip nat inside source static 192.168.88.101 10.0.0.101
ip nat inside source static 192.168.88.102 10.0.0.102
#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
— 10.0.0.101 192.168.88.101 — —
— 10.0.0.102 192.168.88.102 — —

PROBLEM: can’t delete dynamic nat
(config)#no ip nat pool Dynamic-NAT 10.0.0.101 10.0.0.200 prefix-length 24
%Pool Dynamic-NAT in use, cannot destroy
SOLUTION:
disconnect the cable in fa0/1

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s