HP Cisco translation

How to Login

IOS:

switch> enable

switch# configure terminal (conf t)

switch(config)#

HP:

switch# conf t  //because you will be in privileged mode by default

switch(config)#

Basic Setup

IOS:

switch(config)# hostname SW1

SW1(config)# enable secret 0 p@ssw0rd

SW1(config)# clock set 12:00 Feb 10 2011

HP:

switch(config)# hostname SW1

SW1(config)# password all //you will be prompted for an Operator and Manager password, set them the same to basically negate the Operator user

SW1(config)# clock set 02/10/2011

SW1(config)# clock set 12:00

Creating a VLAN, Assign an IP and Setting a Default Gateway

IOS:

SW1(config)# int vlan 100

SW1(vlan-100)# ip address 10.1.100.254 255.255.255.0

SW1(vlan-100)# exit

SW1(config)# ip default-gateway 10.1.100.1

HP:

SW1(config)# int vlan 100

SW1(vlan-100)# ip address 10.1.100.254/24 //255.255.255.0 will also work but the /24 is a handy short cut

SW1(vlan-100)# exit

SW1(config)# ip default-gateway 10.1.100.1

Enabling Layer 3 Routing and Setting a Layer 3 Default Route

IOS:

SW1(config)# ip routing

SW1(config)# ip route 0.0.0.0 0.0.0.0 10.1.100.1

HP:

SW1(config)# ip routing

SW1(config)# ip route 0.0.0.0 0.0.0.0 10.1.100.1

So far so good right? So here come the curve balls, but they’re easy to navigate.

Assigning VLANs

In IOS, you assign VLANs to ports and in HP you assign ports to VLANs. Let’s create an additional VLAN and configure fictitious ports 1-12 on VLAN 100 and 13-24 on VLAN 200.

IOS:

SW1(config)# int vlan 200

SW1(vlan-200)# ip address 10.1.200.254 255.255.255.0

SW1(vlan-200)# exit

SW1(config)# int range fa1-12

SW1(int-range)# switchport access vlan 100

SW1(int-range)# int range fa13-24

SW1(int-range)# switchport access vlan 200

HP:

SW1(config)# vlan 200

SW1(vlan-200)# ip address 10.1.200.254/24 //once again using the short cut

SW1(vlan-200)# exit

SW1(config)# vlan 100

SW1(vlan-100)# untag 1-12

SW1(vlan-100)# vlan 200

SW1(vlan-200)# untag 13-24

So let’s review that. In HP, you create an “access port” by “untagging”? Well, ya, an access port is sending frames without a dot1q tag on it, understood by default servers, PCs, printers, etc. So HP quite literally has you specify that you are sending frames untagged.

Link Aggregation

Moving on, let’s say we want to aggregate ports 23 and 24 into an aggregated link.

IOS:

SW1(config)# int range fa23-24

SW1(int-range)# channel-group 1 on

//a virtual interface is now created called “Port-Channel 1″ and instead of configuring ports 23 and 24 individually, you will now configure Port-Channel 1 as you would any other port

HP:

SW1(config)# trunk trk1 23-24

//a virtual interface is also created here called Trk1 and you will also be applying any any configuration to Trk1 now and not 23 or 24 individually, in fact HP will remove it from the config all together

VLAN Trunking

The last thing I wanted to cover was VLAN Trunking, which is carrying multiple VLANs on a single link. Used for connecting switches that have several VLANs, Firewalls, Routers or virtualization hosts. We’ll configure VLANs 100 and 200 to be carried across our newly created aggregated link.

IOS:

SW1(config)# int po1 //this is how you refer to Port-Channel 1

SW1(po1)# switchport mode trunk

SW1(po1)# switchport trunk allow vlan 100,200

HP:

SW1(config)# vlan 100

SW1(vlan-100)# tag trk1

SW1(vlan-100)# vlan 200

SW1(vlan-200)# tag trk1

I’ve created a quick chart of those last three points for your reference.

22091401

HP has come a long way, I’ve worked on some of their very old gear (because of ProCurve’s lifetime warranty they stay in production for a long time) and configuring the older stuff was easy with the menu system but using a command line is far more robust. CLI is great for backing up configs, running quick config scripts and quickly reviewing how the switch is configured.

Hopefully this post can be of help to you if you are considering HP or have just received your first one and are scratching your head for where to start.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s